box_generator 0.3.3+1
box_generator: ^0.3.3+1 copied to clipboard

Registry generator for Box, a fluent Dart persistence API inspired by SQL.

0
likes
90/ 130
pub points
4%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 19 API elements (5.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:box_generator/box_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.7.11.7.22.7.0
box^0.3.3+10.3.3+10.3.3+1
build^2.0.22.1.12.1.1
source_gen^1.0.21.0.31.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.030.0.0
args-2.3.02.3.0
async-2.8.22.8.2
basic_utils-3.9.13.9.1
bson-1.0.41.0.4
buffer-1.1.11.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.1.12.2.0
file-6.1.26.1.2
fixnum-1.0.01.0.0
glob-2.0.22.0.2
googleapis_auth-1.3.01.3.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
io-1.0.31.0.3
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-1.0.21.0.2
meta-1.7.01.7.0
mongo_dart-0.7.40.7.4
mongo_dart_query-1.0.21.0.2
package_config-2.0.22.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-3.4.03.4.0
pool-1.5.01.5.0
postgres-2.4.22.4.2
pub_semver-2.1.02.1.0
rational-1.2.11.2.1
recase-4.0.04.0.0
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5
vy_string_utils-0.4.30.4.3
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.7.1` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
90
pub points
4%
popularity

Registry generator for Box, a fluent Dart persistence API inspired by SQL.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, box, build, source_gen

More

Packages that depend on box_generator