bolter_flutter 5.0.6
bolter_flutter: ^5.0.6 copied to clipboard

based on bolter library extensions for manage widgets and state

4
likes
80 / 130
pub points
62 %
popularity

We analyzed this package on May 6, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 162 API elements (10.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:bolter_flutter/bolter_flutter.dart that imports:
  • package:bolter_flutter/src/persist/persist_wrapper.dart that imports:
  • package:bolter_flutter/src/persist/persist.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

lib/src/bolter_provider.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/navigation/navigators.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_layout^1.1.01.1.01.1.0
animations^2.0.02.0.02.0.0
bolter^2.0.02.0.02.0.0
flutterflutter0.0.00.0.0
hive^2.0.42.0.42.0.4
hive_flutter^1.0.01.0.01.0.0
provider^5.0.05.0.05.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
equatable-2.0.02.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
meta-1.3.01.3.0
nested-1.0.01.0.0
path-1.8.01.8.0
path_provider-2.0.12.0.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
stream_transform-2.0.02.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Tag detection failed.

Broken import dart:indexed_db

For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

4
likes
80
pub points
62%
popularity

Publisher

renesanse.net

based on bolter library extensions for manage widgets and state

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

after_layout, animations, bolter, flutter, hive, hive_flutter, provider

More

Packages that depend on bolter_flutter