bolter_flutter 1.0.7+1

Flutter Android iOS

based on bolter library extensions for manage widgets and state

Simplest mutable state manager.

Usage #

A simple usage example:

import 'package:bolter/bolter.dart';
import 'package:equatable/equatable.dart';

// ignore: must_be_immutable
class State extends Equatable {
  var value = 0;
  
  @override
  List<Object> get props => [value];
}

void main() {
  final bolter = Bolter(State());
  bolter.stream((state) => state.value).listen((event) {
    print(event);
  });
  bolter.state.value++;
  bolter.shake();
  bolter.state.value++;
  bolter.shake();
}
3
likes
90
pub points
49%
popularity

Publisher

renesanse.net

based on bolter library extensions for manage widgets and state

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

after_layout, animations, bolter, flutter, hive, hive_flutter, platform_info, provider

More

Packages that depend on bolter_flutter