bdaya_token_auth 2.0.0
bdaya_token_auth: ^2.0.0 copied to clipboard

Handle auth token refresh.

1
likes
100/ 130
pub points
59%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 21 API elements (23.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bdaya_repository_pattern^3.0.03.0.03.0.0
jose^0.3.00.3.20.3.2
Transitive dependencies
PackageConstraintCompatibleLatest
asn1lib-1.0.21.0.2
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
crypto_keys-0.3.00.3.0
hive-2.0.42.0.4
http-0.13.30.13.3
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-3.3.43.3.4
quiver-3.0.13.0.1
rxdart-0.26.00.27.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
x509-0.2.20.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:bdaya_token_auth/bdaya_token_auth.dart that imports:
  • package:bdaya_token_auth/src/token_bag_repo.dart that imports:
  • package:bdaya_repository_pattern/bdaya_repository_pattern.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.1+1, Dart 2.14.1.