base_getx 1.0.0
base_getx: ^1.0.0 copied to clipboard

A template app Flutter using GetX

3
likes
90/ 130
pub points
16%
popularity

We analyzed this package 40 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/langvi/base-getX was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 59 API elements (10.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:base_getx/base_getx.dart that imports:
  • package:base_getx/src/request/base_request.dart that imports:
  • package:base_getx/src/const/storage.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS, Linux.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

lib/base_getx.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/base/base_stateful_get.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
awesome_dialog^2.1.02.1.12.1.1
carousel_slider^4.0.04.0.04.0.0
dio^4.0.04.0.44.0.4
flutterflutter0.0.00.0.0
flutter_secure_storage^4.2.04.2.15.0.2
get^4.3.84.5.14.5.1
intl^0.17.00.17.00.17.0
pull_to_refresh^2.0.02.0.02.0.0
shared_preferences^2.0.72.0.92.0.9
validators^3.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flare_flutter-3.0.23.0.2
flutter_lints-1.0.41.0.4
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
lints-1.0.11.0.1
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-2.1.22.1.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
simple_animations-3.2.04.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
supercharged-2.1.12.1.1
supercharged_dart-2.1.12.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.2.0` on flutter_secure_storage does not support the stable version `5.0.0`, that was published 20 days ago.

When flutter_secure_storage is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.