base_flutter_app 2.0.0 copy "base_flutter_app: ^2.0.0" to clipboard
base_flutter_app: ^2.0.0 copied to clipboard

Flutter plugin for manage your app with basic and general functionalities.

0
likes
70/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 70 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

6 out of 114 API elements (5.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: api_source, api_source.ApiSource, api_source.ApiSource.client, api_source.ApiSource.connectivity, api_source.ApiSource.deleteApi.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:base_flutter_app/blocs/bloc.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:base_flutter_app/blocs/bloc.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:base_flutter_app/blocs/bloc.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:base_flutter_app/blocs/bloc.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

ERROR: The argument type 'Object?' can't be assigned to the parameter type 'Map

lib/data_source/db/simple_stream_db_source.dart:18:57

   ╷
18 │         .map((record) => record == null ? null : mapper(record.value));
   │                                                         ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/data_source/db/simple_stream_db_source.dart

ERROR: The named parameter 'vsync' isn't defined.

lib/ui/platform_widgets/error_text_widget.dart:19:7

   ╷
19 │       vsync: this,
   │       ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/platform_widgets/error_text_widget.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
base_data ^2.0.0 2.0.0 2.0.0
base_models ^2.0.0 2.0.0 2.0.0
crypto ^3.0.1 3.0.3 3.0.3
encrypt ^5.0.0 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
meta ^1.3.0 1.11.0 1.14.0
path_provider ^2.0.2 2.1.3 2.1.3
sembast ^3.1.0+2 3.7.1 3.7.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
base_domain - 2.0.0 2.0.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
ffi - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.9.0 3.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
70
pub points
0%
popularity

Publisher

unverified uploader

Flutter plugin for manage your app with basic and general functionalities.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

base_data, base_models, crypto, encrypt, flutter, http, meta, path_provider, sembast

More

Packages that depend on base_flutter_app