backfit 0.0.2+8 copy "backfit: ^0.0.2+8" to clipboard
backfit: ^0.0.2+8 copied to clipboard

Retrofit inspired HTTP Client generator for Dart

4
likes
90/ 140
pub points
14%
popularity

We analyzed this package 6 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

104 out of 188 API elements (55.3 %) have documentation comments.

Some symbols that are missing documentation: backfit, backfit.BackfitClient, backfit.BackfitClient.BackfitClient, backfit.BackfitClient.baseUrl, backfit.BackfitClient.interceptors.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:backfit/backfit.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

WARNING: Unnecessary type check; the result is always 'true'.

lib/src/pretty_logger.dart:205:17

    ╷
205 │             if (request is http.Request) _printBlock(request.body);
    │                 ^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/pretty_logger.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/client.dart:19:9

   ╷
19 │         interceptor.onInterceptResponse(response);
   │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer any 6.4.1 6.4.1
built_collection ^5.1.0 5.1.1 5.1.1
http ^0.13.3 0.13.6 1.2.1
http_parser ^4.0.0 4.0.2 4.0.2
meta ^1.7.0 1.12.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

4
likes
90
pub points
14%
popularity

Publisher

unverified uploader

Retrofit inspired HTTP Client generator for Dart

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, built_collection, http, http_parser, meta

More

Packages that depend on backfit