babel 0.0.4-prerelease copy "babel: ^0.0.4-prerelease" to clipboard
babel: ^0.0.4-prerelease copied to clipboard

Babel is a CLI tool for translations management for Flutter apps.

4
likes
140/ 160
pub points
8%
popularity

We analyzed this package 15 hours ago, and awarded it 140 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/nikosportolos/babel/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

165 out of 299 API elements (55.2 %) have documentation comments.

Some symbols that are missing documentation: all, all.ListAllCommand, all.ListAllCommand.ListAllCommand, all.ListAllCommand.execute, babel.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:babel/babel.dart that imports:
  • package:babel/src/babel.dart that imports:
  • package:dart_cmder/dart_cmder.dart that imports:
  • package:dart_cmder/src/interface/interface.dart that imports:
  • package:dart_cmder/src/interface/arguments/arguments.dart that imports:
  • package:dart_cmder/src/interface/arguments/multi_enum.dart that imports:
  • package:dart_cmder/src/tools/enums.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:babel/babel.dart that imports:
  • package:babel/src/babel.dart that imports:
  • package:dart_cmder/dart_cmder.dart that imports:
  • package:dart_cmder/src/interface/interface.dart that imports:
  • package:dart_cmder/src/interface/arguments/arguments.dart that imports:
  • package:dart_cmder/src/interface/arguments/multi_enum.dart that imports:
  • package:dart_cmder/src/tools/enums.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:babel/babel.dart that imports:
  • package:babel/src/babel.dart that imports:
  • package:dart_cmder/dart_cmder.dart that imports:
  • package:dart_cmder/src/tools/tools.dart that imports:
  • package:dart_cmder/src/tools/finder.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/models/l10n/options.gen.dart:143:17

    ╷
143 │   bool operator ==(Object? other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/l10n/options.gen.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/models/project.gen.dart:48:17

   ╷
48 │   bool operator ==(Object? other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/project.gen.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^6.3.0 6.5.0 6.6.0
ansix ^0.3.1 0.3.3 0.3.3
args ^2.4.2 2.5.0 2.5.0
collection ^1.18.0 1.19.0 1.19.0
dart_cmder ^0.0.5-prerelease 0.0.5-prerelease 0.0.5-prerelease
data_class_plugin ^1.1.0 1.4.1 1.4.1
meta ^1.11.0 1.15.0 1.15.0
path ^1.8.3 1.9.0 1.9.0
trace ^0.0.6-prerelease 0.0.6-prerelease 0.0.6-prerelease
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 70.0.0
_macros - 0.1.0 0.1.0
analyzer_plugin - 0.11.3 0.11.3
async - 2.11.0 2.11.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
date_time_format - 2.0.1 2.0.1
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
macros - 0.1.0-main.0 0.1.2-main.3
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
rxdart - 0.27.7 0.28.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
tachyon - 0.3.0 0.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.