award_app_api_service_flutter 0.0.1 copy "award_app_api_service_flutter: ^0.0.1" to clipboard
award_app_api_service_flutter: ^0.0.1 copied to clipboard

A new Flutter package with customized apis.

0
likes
80/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 76 API elements (3.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: api_service, api_service.APIService, api_service.APIService.callApiGetToken, api_service.APIService.instance, api_service.ServiceType.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/app_configure/app_configure.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/network/models/token_model.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity_plus 2.2.0 2.2.0 5.0.2
dio 4.0.6 4.0.6 5.4.1
flutter flutter 0.0.0 0.0.0
get_it 7.2.0 7.2.0 7.6.7
internet_connection_checker 0.0.1+3 0.0.1+3 1.0.0+1
package_info_plus 1.4.2 1.4.2 5.0.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_plus_linux - 1.3.1 1.3.1
connectivity_plus_macos - 1.2.6 1.2.6
connectivity_plus_platform_interface - 1.2.4 1.2.4
connectivity_plus_web - 1.2.5 1.2.5
connectivity_plus_windows - 1.2.2 1.2.2
dbus - 0.7.4 0.7.10
ffi - 1.2.1 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nm - 0.5.0 0.5.0
package_info_plus_linux - 1.0.5 2.0.0
package_info_plus_macos - 1.3.0 2.0.0
package_info_plus_platform_interface - 1.0.2 2.0.1
package_info_plus_web - 1.0.6 2.0.0
package_info_plus_windows - 1.0.5 3.0.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 2.6.1 5.2.0
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `2.2.0` on connectivity_plus does not support the stable version `2.2.1`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

The constraint `4.0.6` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
80
pub points
0%
popularity

Publisher

unverified uploader

A new Flutter package with customized apis.

Documentation

API reference

License

unknown (LICENSE)

Dependencies

connectivity_plus, dio, flutter, get_it, internet_connection_checker, package_info_plus

More

Packages that depend on award_app_api_service_flutter