artemis 6.18.4
artemis: ^6.18.4 copied to clipboard

Build dart types from GraphQL schemas and queries (using Introspection Query).

109
likes
100 / 130
pub points
92 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 259 out of 316 API elements (82.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.6.11.6.22.0.3
build_config^0.4.50.4.71.0.0
code_builder^3.5.03.7.04.1.0
collection^1.14.131.15.01.15.0
dart_style^1.3.101.3.122.0.3
equatable^1.2.51.2.62.0.3
glob^1.2.01.2.02.0.1
gql^0.12.40.12.40.13.0
gql_code_gen^0.1.50.1.50.1.5
gql_dedupe_link^1.0.101.0.102.0.0
gql_exec^0.2.50.2.50.3.0
gql_http_link^0.3.20.3.20.4.0
gql_link^0.3.1-alpha0.3.10.4.0
http^0.12.20.12.20.13.3
json_annotation^3.1.13.1.14.1.0
meta^1.2.41.7.01.7.0
path^1.7.01.8.01.8.0
recase^3.0.13.0.14.0.0
source_gen^0.9.10+10.9.10+31.0.5
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.023.0.0
analyzer-0.41.22.0.0
async-2.8.12.8.1
built_collection-5.1.05.1.0
built_value-8.1.18.1.1
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.3.30.3.3
clock-1.1.01.1.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-5.2.16.1.2
fixnum-1.0.01.0.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
matcher-0.12.100.12.10
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
pub_semver-2.0.02.0.0
pubspec_parse-0.1.81.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 16 issues. Showing the first 2:

The constraint `^1.6.1` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

The constraint `^0.4.5` on build_config does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions build_config to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.