gql_code_builder 0.0.9

  • Readme
  • Changelog
  • Example
  • Installing
  • 77

Dart code builders taking *.graphql documents and SDL to build useful classes.

The API is currently unstable and only serves as the base for package:gql_build builders.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.9 #

  • remove duplicate ast imports

0.0.8 #

  • escape reserved and private names

0.0.7 #

  • fix schema url bug

0.0.6 #

  • fix nullable url bug

0.0.5 #

  • rework builders to be based on SourceNode to handle imports
  • combine data and fragment builder
  • no more global fragments file
  • combine schema builders
  • refer to other generated files by using URI fragments

0.0.4 #

  • upgrade package:gql_pedantic

0.0.3 #

  • Support for fragment builder

0.0.2 #

  • Split off var_builder off of req_builder

0.0.1 #

  • Spun off of package:gql_code_gen

example/README.md

The API is currently unstable. See package:gql_build for usage examples.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gql_code_builder: ^0.0.9

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gql_code_builder/ast.dart';
import 'package:gql_code_builder/data.dart';
import 'package:gql_code_builder/op.dart';
import 'package:gql_code_builder/req.dart';
import 'package:gql_code_builder/schema.dart';
import 'package:gql_code_builder/source.dart';
import 'package:gql_code_builder/var.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
77
Learn more about scoring.

We analyzed this package on Apr 6, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
built_collection ^4.0.0 4.3.2
code_builder ^3.2.0 3.2.1
gql ^0.12.1 0.12.2
meta ^1.1.7 1.1.8
Transitive dependencies
built_value 7.0.9
charcode 1.1.3
collection 1.14.12
fixnum 0.10.11
matcher 0.12.6
path 1.6.4
quiver 2.1.3
source_span 1.7.0
stack_trace 1.9.3
term_glyph 1.1.0
Dev dependencies
gql_pedantic ^1.0.1