archethic_lib_dart 1.0.25 icon indicating copy to clipboard operation
archethic_lib_dart: ^1.0.25 copied to clipboard

Archethic dart library for Flutter for Node and Browser. This library aims to provide a easy way to create Archethic transaction and to send them over the network

5
likes
120/ 140
pub points
34%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: AGPL-3.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 191 out of 874 API elements (21.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

SDK issues found:

Package is not compatible with the Dart SDK.

Because:

  • archethic_lib_dart that depends on:
  • graphql_flutter that is a package requiring flutter.
* ✓ Android * ✓ iOS * ✓ Windows * ✓ Linux * ✓ MacOS * ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'dart:math'.

lib/src/utils/utils.dart:4:8

  ╷
4 │ import 'dart:math';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/utils/utils.dart

INFO: The name Endian is shown, but isn’t used.

lib/src/utils/utils.dart:5:42

  ╷
5 │ import 'dart:typed_data' show Uint8List, Endian;
  │                                          ^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/utils/utils.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^3.0.23.0.23.0.2
crypto_keys^0.3.00.3.00.3.0
ecdsa^0.0.40.0.40.0.4
elliptic^0.3.80.3.80.3.8
gql_exec^0.4.00.4.00.4.1
gql_link^0.4.20.4.20.5.0
graphql_flutter^5.1.1-beta.35.1.1-beta.45.1.1-beta.4
hex^0.2.00.2.00.2.0
http^0.13.40.13.50.13.5
jwk^0.1.10.1.10.1.1
phoenix_socket^0.5.30.5.30.6.1
pinenacl^0.5.10.5.10.5.1
pointycastle^3.6.13.6.23.6.2
secp256k1^0.3.00.3.00.3.0
x25519^0.1.10.1.10.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
adaptive_number-1.0.01.0.0
args-2.3.12.3.1
async-2.9.02.9.0
characters-1.2.11.2.1
collection-1.16.01.16.0
connectivity_plus-2.3.72.3.7
connectivity_plus_linux-1.3.11.3.1
connectivity_plus_macos-1.2.41.2.4
connectivity_plus_platform_interface-1.2.11.2.1
connectivity_plus_web-1.2.31.2.3
connectivity_plus_windows-1.2.21.2.2
convert-3.0.23.0.2
cryptography-2.0.52.0.5
dbus-0.7.80.7.8
equatable-2.0.52.0.5
ffi-2.0.12.0.1
file-6.1.46.1.4
fixnum-1.0.11.0.1
flutter-0.0.00.0.0
flutter_hooks-0.18.5+10.18.5+1
flutter_web_plugins-0.0.00.0.0
gql-0.13.10.14.0
gql_dedupe_link-2.0.22.0.3
gql_error_link-0.2.20.2.3
gql_http_link-0.4.20.4.4+1
gql_transform_link-0.2.20.2.2
graphql-5.1.2-beta.45.1.2-beta.4
hive-2.2.32.2.3
http_parser-4.0.14.0.1
js-0.6.40.6.4
logging-1.0.21.0.2
matcher-0.12.120.12.12
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
ninja_asn1-2.0.02.0.0
nm-0.5.00.5.0
normalize-0.6.0+10.7.1
path-1.8.21.8.2
path_provider-2.0.112.0.11
path_provider_android-2.0.202.0.20
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.1.32.1.3
pedantic-1.11.11.11.1
petitparser-5.0.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
quiver-3.1.03.1.0
rxdart-0.27.50.27.5
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
stream_channel-2.1.12.1.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.63.0.6
vector_math-2.1.22.1.4
web_socket_channel-2.2.02.2.0
win32-3.0.03.0.0
xdg_directories-0.2.0+20.2.0+2
xml-6.1.06.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.2` on gql_link does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions gql_link to update the constraint.

The constraint `^0.5.3` on phoenix_socket does not support the stable version `0.6.0`, that was published 8 days ago.

When phoenix_socket is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions phoenix_socket to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.17, Dart 2.18.0.

5
likes
120
pub points
34%
popularity

Publisher

unverified uploader

Archethic dart library for Flutter for Node and Browser. This library aims to provide a easy way to create Archethic transaction and to send them over the network

Homepage

Documentation

API reference

License

Icon for licenses.AGPL-3.0 (LICENSE)

Dependencies

crypto, crypto_keys, ecdsa, elliptic, gql_exec, gql_link, graphql_flutter, hex, http, jwk, phoenix_socket, pinenacl, pointycastle, secp256k1, x25519

More

Packages that depend on archethic_lib_dart