appengine 0.12.1
appengine: ^0.12.1 copied to clipboard

Support for using Dart as a custom runtime on Google App Engine Flexible Environment

11
likes
65 / 130
pub points
71 %
popularity

We analyzed this package on May 7, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:70:39

   ╷
70 │ <p>This will serve the application at <a href="http://localhost:8080">localhost:8080</a>!</p>
   │                                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 65 API elements (23.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:appengine/appengine.dart that imports:
  • package:appengine/src/errors.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 668 issues. Showing the first 2:

INFO: 'copyWith' is deprecated and shouldn't be used. Using this can add significant size overhead to your binary. Use [GeneratedMessageGenericExtensions.rebuild] instead. Will be removed in next major version.

lib/src/grpc_api/dart/google/api/auth.pb.dart:31:13

   ╷
31 │       super.copyWith((message) => updates(message as Authentication));
   │             ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/grpc_api/dart/google/api/auth.pb.dart

INFO: 'copyWith' is deprecated and shouldn't be used. Using this can add significant size overhead to your binary. Use [GeneratedMessageGenericExtensions.rebuild] instead. Will be removed in next major version.

lib/src/grpc_api/dart/google/api/auth.pb.dart:70:13

   ╷
70 │       super.copyWith((message) => updates(message as AuthenticationRule));
   │             ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/grpc_api/dart/google/api/auth.pb.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
fixnum^0.10.00.10.111.0.0
gcloud^0.7.00.7.30.7.3
googleapis_auth^0.2.120.2.12+11.1.0
grpc^2.2.02.9.03.0.0
http^0.12.00.12.20.13.3
logging^0.11.00.11.41.0.1
path^1.6.01.8.01.8.0
protobuf^1.0.01.1.32.0.0
stack_trace^1.9.01.10.01.10.0
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-0.2.11.0.0
archive-2.0.133.1.2
args-1.6.02.1.0
async-2.6.12.6.1
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
googleapis-0.56.12.0.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.10.0` on fixnum does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions fixnum to update the constraint.

The constraint `^0.2.12` on googleapis_auth does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions googleapis_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.