app_package_maker_zip 0.2.3 copy "app_package_maker_zip: ^0.2.3" to clipboard
app_package_maker_zip: ^0.2.3 copied to clipboard

Create a zip package for your app.

0
likes
100/ 140
pub points
6%
popularity

We analyzed this package 5 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: app_package_maker_zip,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: app_package_maker_zip.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 9 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: app_package_maker_zip, app_package_maker_zip.AppPackageMakerZip, app_package_maker_zip.AppPackageMakerZip.AppPackageMakerZip, app_package_maker_zip.AppPackageMakerZip.isSupportedOnCurrentPlatform, app_package_maker_zip.AppPackageMakerZip.loadMakeConfig.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:app_package_maker_zip/app_package_maker_zip.dart that imports:
  • package:app_package_maker_zip/src/app_package_maker_zip.dart that imports:
  • package:archive/archive_io.dart that imports:
  • package:archive/src/io/zip_file_encoder.dart that imports:
  • package:archive/src/io/output_file_stream.dart that imports:
  • package:archive/src/io/file_handle.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
app_package_maker ^0.2.3 0.2.5 0.3.6
archive ^3.1.5 3.5.1 3.5.1
Transitive dependencies
Package Constraint Compatible Latest
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0
mustache_template - 2.0.0 2.0.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.3` on app_package_maker does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions app_package_maker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.