app_feedback 0.0.2 icon indicating copy to clipboard operation
app_feedback: ^0.0.2 copied to clipboard

A Flutter package for getting app feedback from users.

19
likes
110/ 140
pub points
51%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 85 API elements (61.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: The import of 'package:app_feedback/src/model/options.dart' is unnecessary because all of the used elements are also provided by the import of 'package:app_feedback/app_feedback.dart'.

lib/src/cubit/feedback_cubit.dart:3:8

  ╷
3 │ import 'package:app_feedback/src/model/options.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/cubit/feedback_cubit.dart

INFO: The import of 'package:app_feedback/src/model/feedback.dart' is unnecessary because all of the used elements are also provided by the import of 'package:app_feedback/app_feedback.dart'.

lib/src/cubit/feedback_cubit.dart:6:8

  ╷
6 │ import 'package:app_feedback/src/model/feedback.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/cubit/feedback_cubit.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_bloc^7.0.17.3.38.1.1
shared_preferences^2.0.62.0.152.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
bloc-7.2.18.1.0
characters-1.2.11.2.1
collection-1.16.01.16.0
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.4
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
nested-1.0.01.0.0
path-1.8.21.8.2
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
provider-6.0.36.0.3
shared_preferences_android-2.0.132.0.13
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4
win32-3.0.03.0.0
xdg_directories-0.2.0+20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.1` on flutter_bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Flutter 3.3.3, Dart 2.18.2.

19
likes
110
pub points
51%
popularity

Publisher

unverified uploader

A Flutter package for getting app feedback from users.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

flutter, flutter_bloc, shared_preferences

More

Packages that depend on app_feedback