api_error_parser 0.0.5
api_error_parser: ^0.0.5

Flutter Android iOS web

Parsing responses from api and handling errors in the Dart/Flutter

0
likes
80 / 110
pub points
57 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
  warning: api_error_parser has no library level documentation comments, from api_error_parser: (file:///tmp/pub-dartlang-dartdocHNQYNI/pkg/lib/api_parser.dart:1:9)
  warning: api_error_parser has no library level documentation comments, from api_error_parser: (file:///tmp/pub-dartlang-dartdocHNQYNI/pkg/lib/api_error_parser.dart:1:9)
  error: failed to write file at: api_error_parser/api_error_parser-library.html
    for symbol api_error_parser: (file:///tmp/pub-dartlang-dartdocHNQYNI/pkg/lib/api_error_parser.dart:1:9)
    conflicting with file already generated by api_error_parser: (file:///tmp/pub-dartlang-dartdocHNQYNI/pkg/lib/api_parser.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            api_error_parser conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: dartdoc generated a broken link to: LICENSE, linked to from package-api_error_parser: file:///tmp/pub-dartlang-dartdocHNQYNI/pkg
found 3 warnings and 1 error
Unhandled exception:
dartdoc encountered 1 errors while processing.
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:231:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#2      _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#3      _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/entity/api_response/api_response_entity.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/entity/api_response/api_response_pagination_entity.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
57%
popularity

Parsing responses from api and handling errors in the Dart/Flutter

Homepage

Documentation

API reference

Uploader

mikhajlyuk@gmail.com

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on api_error_parser