apex_flutter_plugin 1.1.1+1
apex_flutter_plugin: ^1.1.1+1 copied to clipboard

ApexTeam Flutter Plugin - A simple flutter plugin for ApexTeam fellas which supports http request management, request encryption, request cancellation, ... .

5
likes
70 / 130
pub points
50 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitlab.com/1839491/apexflutterlogin was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 147 API elements (19.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:apex_flutter_plugin/apex_flutter_plugin.dart that declares support for platforms: Android
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^3.0.33.0.63.0.6
encrypt^5.0.05.0.05.0.0
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
http^0.13.00.13.30.13.3
http_parser^4.0.04.0.04.0.0
pedantic^1.11.01.11.01.11.0
pointycastle^3.0.13.1.13.1.1
universal_html^2.0.82.0.82.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.1.12.1.1
asn1lib-1.0.21.0.2
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.4.00.4.0
connectivity_macos-0.2.00.2.0
connectivity_platform_interface-2.0.12.0.1
convert-3.0.03.0.0
crypto-3.0.13.0.1
csslib-0.17.00.17.0
html-0.15.00.15.0
js-0.6.30.6.3
meta-1.3.01.4.0
path-1.8.01.8.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_io-2.0.42.0.4
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

5
likes
70
pub points
50%
popularity

Publisher

packs.apexteam.net

ApexTeam Flutter Plugin - A simple flutter plugin for ApexTeam fellas which supports http request management, request encryption, request cancellation, ... .

Repository (GitLab)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

connectivity, encrypt, flutter, flutter_web_plugins, http, http_parser, pedantic, pointycastle, universal_html

More

Packages that depend on apex_flutter_plugin