anyline_plugin 24.1.0
anyline_plugin: ^24.1.0 copied to clipboard

Flutter Plugin for Anyline OCR, which allows you to scan all kinds of numbers, characters, text and codes.

1
likes
80 / 110
pub points
42 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 31 API elements (32.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:anyline_plugin/anyline_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This function has a return type of 'FutureOr

lib/anyline_plugin.dart:29:18

   ╷
29 │   Future<String> startScanning(String configJson) async {
   │                  ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/anyline_plugin.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
permission_handler^5.0.1+15.1.0+26.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
permission_handler_platform_interface-2.0.23.1.3
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.1+1` on permission_handler does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
80
pub points
42%
popularity

Flutter Plugin for Anyline OCR, which allows you to scan all kinds of numbers, characters, text and codes.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

daniel@anyline.com

License

MPL 2.0 (LICENSE)

Dependencies

flutter, permission_handler

More

Packages that depend on anyline_plugin