angel_auth 2.1.5+1
angel_auth: ^2.1.5+1 copied to clipboard

A complete authentication plugin for Angel. Includes support for stateless JWT tokens, Basic Auth, and more.

0
likes
80 / 130
pub points
76 %
popularity

We analyzed this package on May 13, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 48 out of 95 API elements (50.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_auth/angel_auth.dart that imports:
  • package:angel_auth/src/strategy.dart that imports:
  • package:angel_auth/src/options.dart that imports:
  • package:angel_auth/src/auth_token.dart that imports:
  • package:angel_framework/angel_framework.dart that imports:
  • package:angel_framework/src/core/core.dart that imports:
  • package:angel_framework/src/core/service.dart that imports:
  • package:angel_framework/src/core/server.dart that imports:
  • package:angel_framework/src/core/routable.dart that imports:
  • package:angel_framework/src/core/response_context.dart that imports:
  • package:angel_framework/src/core/request_context.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 29 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/auth_token.dart:65:7

   ╷
65 │       throw AngelHttpException.notAuthenticated(message: "Invalid JWT.");
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/auth_token.dart

INFO: DO use curly braces for all flow control structures.

lib/src/auth_token.dart:75:7

   ╷
75 │       throw AngelHttpException.notAuthenticated(message: "Invalid JWT.");
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/auth_token.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-rc.62.1.12.1.1
charcode^1.0.01.2.01.2.0
collection^1.0.01.15.01.15.0
crypto^2.0.02.1.53.0.1
http_parser^3.0.03.1.44.0.0
meta^1.0.01.3.01.3.0
quiver_hashcode^2.0.02.0.03.0.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
combinator-1.1.01.1.0
convert-2.1.13.0.0
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
http2-1.0.12.0.0
http_server-0.9.8+31.0.0
intl-0.17.00.17.0
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
mime-0.9.71.0.0
mock_request-1.0.71.0.7
path-1.8.01.8.0
quiver-2.1.53.0.1
recase-2.0.14.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.0` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^3.0.0` on http_parser does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions http_parser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
80
pub points
76%
popularity

Publisher

angel-dart.dev

A complete authentication plugin for Angel. Includes support for stateless JWT tokens, Basic Auth, and more.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, charcode, collection, crypto, http_parser, meta, quiver_hashcode

More

Packages that depend on angel_auth