angel3_security 3.1.0
angel3_security: ^3.1.0 copied to clipboard

Angel3 infrastructure for improving security, rate limiting, and more

0
likes
120/ 130
pub points
0%
popularity

We analyzed this package on Oct 20, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 44 out of 52 API elements (84.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel3_security/angel3_security.dart that imports:
  • package:angel3_security/src/service_rate_limiter.dart that imports:
  • package:angel3_security/src/rate_limiter.dart that imports:
  • package:angel3_framework/angel3_framework.dart that imports:
  • package:angel3_framework/src/core/core.dart that imports:
  • package:angel3_framework/src/core/service.dart that imports:
  • package:angel3_framework/src/core/server.dart that imports:
  • package:angel3_framework/src/core/routable.dart that imports:
  • package:angel3_framework/src/core/response_context.dart that imports:
  • package:angel3_framework/src/core/request_context.dart that imports:
  • package:belatuk_http_server/belatuk_http_server.dart that imports:
  • package:belatuk_http_server/src/http_multipart_form_data.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel3_framework^4.2.04.2.14.2.1
crypto^3.0.13.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
angel3_container-3.1.13.1.1
angel3_http_exception-3.0.23.0.2
angel3_mock_request-2.0.22.0.2
angel3_model-3.1.03.1.0
angel3_route-5.2.05.2.0
belatuk_code_buffer-3.0.23.0.2
belatuk_combinator-3.0.13.0.1
belatuk_http_server-2.1.02.1.0
belatuk_merge_map-3.0.23.0.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
file-6.1.26.1.2
http2-2.0.02.0.0
http_parser-4.0.04.0.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
path-1.8.01.8.0
quiver-3.0.1+13.0.1+1
recase-4.0.04.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-2.0.02.0.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
120
pub points
0%
popularity

Publisher

dukefirehawk.com

Angel3 infrastructure for improving security, rate limiting, and more

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

angel3_framework, crypto

More

Packages that depend on angel3_security