angel3_jael 4.0.0
angel3_jael: ^4.0.0 copied to clipboard

Angel support for the Jael templating engine, similar to Blade or Liquid.

0
likes
120 / 130
pub points
52 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel3_jael/angel3_jael.dart that imports:
  • package:jael3_preprocessor/jael3_preprocessor.dart that imports:
  • package:jael3/jael3.dart that imports:
  • package:jael3/src/renderer.dart that imports:
  • package:jael3/src/text/scanner.dart that imports:
  • package:jael3/src/ast/ast.dart that imports:
  • package:jael3/src/ast/new.dart that imports:
  • package:jael3/src/ast/member.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel3_code_buffer^2.0.02.0.32.0.3
angel3_framework^4.0.04.1.14.1.1
angel3_symbol_table^2.0.02.0.22.0.2
file^6.0.06.1.26.1.2
jael3^4.0.04.0.04.0.0
jael3_preprocessor^4.0.04.0.14.0.1
logging^1.0.11.0.11.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
angel3_combinator-2.0.22.0.2
angel3_container-3.0.23.0.2
angel3_http_exception-3.0.23.0.2
angel3_merge_map-2.0.22.0.2
angel3_mock_request-2.0.22.0.2
angel3_model-3.0.13.0.1
angel3_route-5.0.15.0.1
args-2.2.02.2.0
belatuk_http_server-2.0.12.0.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
http2-2.0.02.0.0
http_parser-4.0.04.0.0
matcher-0.12.100.12.10
meta-1.7.01.7.0
mime-1.0.01.0.0
path-1.8.01.8.0
quiver-3.0.13.0.1
recase-4.0.04.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-2.0.02.0.0
typed_data-1.3.01.3.0
uuid-3.0.43.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.