amplify_datastore 1.8.0 copy "amplify_datastore: ^1.8.0" to clipboard
amplify_datastore: ^1.8.0 copied to clipboard

The Amplify Flutter DataStore category plugin, providing a queryable, on-device data store.

34
likes
130/ 140
pub points
94%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/aws-amplify/amplify-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

175 out of 427 API elements (41.0 %) have documentation comments.

Some symbols that are missing documentation: amplify_datastore, amplify_datastore.AmplifyDataStore, amplify_datastore.AmplifyDataStore.clear, amplify_datastore.AmplifyDataStore.delete, amplify_datastore.AmplifyDataStore.observe.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amplify_datastore/amplify_datastore.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amplify_datastore/amplify_datastore.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amplify_datastore/amplify_datastore.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amplify_datastore/amplify_datastore.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Statements in an if should be enclosed in a block.

lib/src/method_channel_datastore.dart:43:11

   ╷
43 │           throw StateError("Native calling non existent ErrorHandler in Dart");
   │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/method_channel_datastore.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/method_channel_datastore.dart:52:11

   ╷
52 │ ┌           throw StateError(
53 │ └               "Native calling non existent ConflictHandler in Dart");
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/method_channel_datastore.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amplify_core >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_datastore_plugin_interface >=1.8.0 <1.9.0 1.8.0 1.8.0
async ^2.10.0 2.11.0 2.11.0
collection ^1.14.13 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.11.0 1.14.0
plugin_platform_interface ^2.0.0 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
aws_common - 0.6.4 0.6.4
aws_signature_v4 - 0.5.2 0.5.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
graphs - 2.3.1 2.3.1
http2 - 2.3.0 2.3.0
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
mime - 1.0.5 1.0.5
os_detect - 2.0.1 2.0.1
path - 1.9.0 1.9.0
retry - 3.1.2 3.1.2
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_transform - 2.1.0 2.1.0
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.