amlv 1.0.2 copy "amlv: ^1.0.2" to clipboard
amlv: ^1.0.2 copied to clipboard

Inspired by Apple Music's Lyrics Viewer, this package provides a widget that displays lyrics(srt, lrc, json) in a beautiful way.

4
likes
150/ 160
pub points
38%
popularity

We analyzed this package 4 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

171 out of 264 API elements (64.8 %) have documentation comments.

Some symbols that are missing documentation: amlv, amlv.AndroidAudioFocus.AndroidAudioFocus.fromInt, amlv.AndroidAudioFocus.value, amlv.AndroidAudioMode.AndroidAudioMode.fromInt, amlv.AndroidAudioMode.value.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:amlv/amlv.dart that imports:
  • package:amlv/src/parser/lyric_parser.dart that imports:
  • package:audioplayers/audioplayers.dart that imports:
  • package:audioplayers/src/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audioplayers ^5.2.0 5.2.1 6.0.0
flutter flutter 0.0.0 0.0.0
lyrics_parser ^1.0.0-nullsafety.0 1.0.0-nullsafety.0 1.0.0-nullsafety.0
scroll_to_index ^3.0.1 3.0.1 3.0.1
simple_animations ^5.0.2 5.0.2 5.0.2
srt_parser_2 ^2.0.2 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
audioplayers_android - 4.0.3 5.0.0
audioplayers_darwin - 5.0.2 6.0.0
audioplayers_linux - 3.1.0 4.0.0
audioplayers_platform_interface - 6.1.0 7.0.0
audioplayers_web - 4.1.0 5.0.0
audioplayers_windows - 3.1.0 4.0.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
csslib - 0.17.3 1.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.2.0` on audioplayers does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
150
pub points
38%
popularity

Publisher

verified publisherlhamy.codes

Inspired by Apple Music's Lyrics Viewer, this package provides a widget that displays lyrics(srt, lrc, json) in a beautiful way.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers, flutter, lyrics_parser, scroll_to_index, simple_animations, srt_parser_2

More

Packages that depend on amlv