alice_lightweight 1.0.2
alice_lightweight: ^1.0.2 copied to clipboard

Flutter Android iOS

Lightweight Alice version. Removed additional dependencies except dio.

3
likes
70 / 110
pub points
54 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 48 out of 224 API elements (21.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:alice_lightweight/alice.dart that imports:
  • package:alice_lightweight/core/alice_http_client_adapter.dart that imports:
  • package:alice_lightweight/core/alice_core.dart that imports:
  • package:alice_lightweight/ui/page/alice_calls_list_screen.dart that imports:
  • package:alice_lightweight/utils/alice_share_logs.dart that imports:
  • package:share/share.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used.

lib/core/alice_core.dart:16:30

   ╷
16 │       BehaviorSubject.seeded(List());
   │                              ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/core/alice_core.dart

INFO: 'List' is deprecated and shouldn't be used.

lib/core/alice_core.dart:119:22

    ╷
119 │     callsSubject.add(List());
    │                      ^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/core/alice_core.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.93.0.103.0.10
http^0.12.20.12.20.12.2
path_provider^1.6.271.6.271.6.27
rxdart^0.24.10.24.10.25.0
share^0.6.5+40.6.5+40.6.5+4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
mime-0.9.70.9.7
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+80.0.4+8
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.24.1` on rxdart does not support the latest published version `0.25.0`

pubspec.yaml:15:11

   ╷
15 │   rxdart: ^0.24.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
70
pub points
54%
popularity

Lightweight Alice version. Removed additional dependencies except dio.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

flutter.dash.kit@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

dio, flutter, http, path_provider, rxdart, share

More

Packages that depend on alice_lightweight