adaptive_theme_fluent_ui 1.3.0 copy "adaptive_theme_fluent_ui: ^1.3.0" to clipboard
adaptive_theme_fluent_ui: ^1.3.0 copied to clipboard

An extension package of adaptive_theme library that supports dynamic theming for fluent_ui package.

3
likes
140/ 140
pub points
47%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

13 out of 14 API elements (92.9 %) have documentation comments.

Some symbols that are missing documentation: adaptive_theme_fluent_ui.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
adaptive_theme >=3.6.0 <4.0.0 3.6.0 3.6.0
fluent_ui >=4.3.0 <5.0.0 4.8.6 4.8.6
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_localizations - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
intl - 0.18.1 0.19.0
material_color_utilities - 0.8.0 0.8.0
math_expressions - 2.4.0 2.4.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
recase - 4.1.0 4.1.0
scroll_pos - 0.5.0 0.5.0
shared_preferences - 2.2.2 2.2.2
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

3
likes
140
pub points
47%
popularity

Publisher

verified publisherbirju.dev

An extension package of adaptive_theme library that supports dynamic theming for fluent_ui package.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

adaptive_theme, fluent_ui, flutter

More

Packages that depend on adaptive_theme_fluent_ui