zefyr_apex 1.0.3
zefyr_apex: ^1.0.3 copied to clipboard

Clean, minimalistic and collaboration-ready rich text editor for Flutter. Fork with zefyr and apex make it better.

0
likes
65/ 130
pub points
0%
popularity

We analyzed this package 38 hours ago, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitlab.com/apexzefyr/zefyr was unreachable.

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 234 out of 444 API elements (52.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:zefyr_apex/zefyr.dart that imports:
  • package:zefyr_apex/src/widgets/text_line.dart that imports:
  • package:zefyr_apex/src/widgets/editor.dart that imports:
  • package:video_thumbnail/video_thumbnail.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

lib/src/rendering/editable_text_block.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/rendering/editable_text_line.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
characters^1.0.01.1.01.2.0
collection^1.14.61.15.01.15.0
emojis^0.9.30.9.90.9.9
file_picker^2.1.5+12.1.74.2.7
flutterflutter0.0.00.0.0
flutter_highlight^0.6.00.6.00.7.0
highlight^0.6.00.6.00.7.0
image_picker^0.6.7+210.6.7+220.8.4+4
intl^0.16.10.16.10.17.0
just_audio^0.6.90.6.15+10.9.18
meta^1.1.01.7.01.7.0
mime^0.9.70.9.71.0.1
modal_bottom_sheet^1.0.0+11.0.0+12.0.0
notus_apex^1.0.01.0.01.0.0
quill_delta^2.0.02.0.02.0.0
quiver_hashcode^2.0.02.0.03.0.0+1
shamsi_date^0.9.10.9.11.0.0
solar_datepicker^0.0.1+10.0.1+31.0.2
syncfusion_flutter_core^18.4.3518.4.4919.3.57
syncfusion_flutter_datepicker^18.4.41-beta18.4.49-beta19.3.57
url_launcher^5.0.05.7.106.0.17
video_player^1.0.11.0.12.2.7
video_thumbnail^0.2.5+10.2.5+10.4.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
audio_session-0.0.110.1.6+1
charcode-1.3.11.3.1
convert-2.1.13.0.1
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_plugin_android_lifecycle-1.0.112.0.5
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.4.1
js-0.6.30.6.3
just_audio_platform_interface-2.0.14.0.0
just_audio_web-0.2.30.4.2
path-1.8.01.8.0
path_provider-1.6.282.0.7
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.4
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
rxdart-0.25.00.27.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.5
url_launcher_windows-0.0.1+32.0.2
uuid-2.2.23.0.5
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 16 issues. Showing the first 2:

The constraint `^2.1.5+1` on file_picker does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^0.6.0` on flutter_highlight does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_highlight to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.