z_components 0.8.2
z_components: ^0.8.2

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

4
likes
50 / 110
pub points
64 %
popularity

We analyzed this package on Nov 15, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 71 out of 1284 API elements (5.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:z_components/api/identity-server/i-identity-server.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:z_components/api/identity-server/i-identity-server.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:z_components/api/identity-server/i-identity-server.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:z_components/api/identity-server/i-identity-server.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 47 issues. Showing the first 2:

ERROR: The argument type 'ZDatabase Function(dynamic)' can't be assigned to the parameter type 'IContext Function()'.

lib/infra/db/database.dart:32:55

   ╷
32 │     Injector.appInstance.registerDependency<IContext>((_) => this);
   │                                                       ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/infra/db/database.dart

INFO: Unused import: 'package:z_components/view-model/user-claims.dart'.

lib/api/identity-server/i-identity-server.dart:1:8

  ╷
1 │ import 'package:z_components/view-model/user-claims.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/api/identity-server/i-identity-server.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^1.1.11.1.32.3.3
configurable_expansion_tile^1.0.01.0.01.0.0
cpf_cnpj_validator^1.0.51.0.51.0.5
dio^2.0.42.2.23.0.10
email_validator^1.0.01.0.61.0.6
flutterflutter0.0.00.0.0
flutter_circular_chart^0.1.00.1.00.1.0
flutter_localizationsflutter0.0.00.0.0
http^0.12.0+10.12.20.12.2
injector^1.0.81.0.91.0.9
mask_shifter^0.1.00.1.00.1.0
mask_text_input_formatter^1.0.21.1.01.1.0
path_provider^1.2.01.6.241.6.24
pin_code_text_field^1.3.61.7.11.7.1
provider^2.0.12.0.1+14.3.2+2
shared_preferences^0.5.3+10.5.12+40.5.12+4
sqflite^1.1.6+41.3.2+11.3.2+1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.0-nullsafety.12.5.0-nullsafety.3
boolean_selector-2.1.0-nullsafety.12.1.0-nullsafety.3
characters-1.1.0-nullsafety.31.1.0-nullsafety.5
charcode-1.2.0-nullsafety.11.2.0-nullsafety.3
clock-1.1.0-nullsafety.11.1.0-nullsafety.3
collection-1.15.0-nullsafety.31.15.0-nullsafety.5
convert-2.1.12.1.1
cookie_jar-1.0.11.0.1
crypto-2.1.52.1.5
fake_async-1.2.0-nullsafety.11.2.0-nullsafety.3
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_cache_manager-1.4.22.0.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
matcher-0.12.10-nullsafety.10.12.10-nullsafety.3
meta-1.3.0-nullsafety.31.3.0-nullsafety.6
path-1.8.0-nullsafety.11.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
rxdart-0.24.10.24.1
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+30.0.1+3
sky_engine-0.0.990.0.99
source_span-1.8.0-nullsafety.21.8.0-nullsafety.4
sqflite_common-1.0.2+11.0.2+1
stack_trace-1.10.0-nullsafety.11.10.0-nullsafety.6
stream_channel-2.1.0-nullsafety.12.1.0-nullsafety.3
string_scanner-1.1.0-nullsafety.11.1.0-nullsafety.3
synchronized-2.2.0+22.2.0+2
term_glyph-1.2.0-nullsafety.11.2.0-nullsafety.3
test_api-0.2.19-nullsafety.20.2.19-nullsafety.6
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.5
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.1.1` on cached_network_image does not support the latest published version `2.3.3`

pubspec.yaml:25:25

   ╷
25 │   cached_network_image: ^1.1.1
   │                         ^^^^^^
   ╵
The constraint `^2.0.4` on dio does not support the latest published version `3.0.10`

pubspec.yaml:29:8

   ╷
29 │   dio: ^2.0.4
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
50
pub points
64%
popularity

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

victortmarques@gmail.com

License

unknown (LICENSE)

Dependencies

cached_network_image, configurable_expansion_tile, cpf_cnpj_validator, dio, email_validator, flutter, flutter_circular_chart, flutter_localizations, http, injector, mask_shifter, mask_text_input_formatter, path_provider, pin_code_text_field, provider, shared_preferences, sqflite

More

Packages that depend on z_components