z_components 0.5.8
z_components: ^0.5.8 copied to clipboard

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

4
likes
50 / 110
pub points
66 %
popularity

We analyzed this package on Apr 11, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 69 out of 1258 API elements (5.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:z_components/api/quadro-pessoal-service.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 99 issues. Showing the first 2:

ERROR: The named parameter 'actionsForegroundColor' isn't defined.

lib/components/z_navigationbar.dart:71:7

   ╷
71 │       actionsForegroundColor: this.actionsForegroundColor,
   │       ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/components/z_navigationbar.dart

ERROR: The argument type 'ZDatabase Function(dynamic)' can't be assigned to the parameter type 'IContext Function()'.

lib/infra/db/database.dart:35:55

   ╷
35 │     Injector.appInstance.registerDependency<IContext>((_) => this);
   │                                                       ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/infra/db/database.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^1.1.11.1.33.0.0
configurable_expansion_tile^1.0.01.0.01.0.0
cpf_cnpj_validator^1.0.51.0.51.0.5
email_validator^1.0.01.0.62.0.1
flare_flutter^1.5.11.8.33.0.0
flutterflutter0.0.00.0.0
flutter_circular_chart^0.1.00.1.00.1.0
flutter_localizationsflutter0.0.00.0.0
http^0.12.0+10.12.20.13.1
injector^1.0.81.0.92.0.0
mask_shifter^0.1.00.1.00.1.0
path_provider^1.2.01.6.282.0.1
pin_code_text_field^1.3.61.8.01.8.0
provider^2.0.12.0.1+15.0.0
sqflite^1.1.6+41.3.2+42.0.0+3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
fake_async-1.2.01.2.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flare_dart-2.3.42.3.4
flutter_cache_manager-1.4.23.0.1
http_parser-3.1.44.0.0
intl-0.17.00.17.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
rxdart-0.24.10.26.0
sky_engine-0.0.990.0.99
source_span-1.8.01.8.1
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
test_api-0.2.190.3.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.1.1` on cached_network_image does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^1.0.0` on email_validator does not support the stable version `2.0.1`, that was published 28 days ago.

When email_validator is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions email_validator to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.