xrpc 0.5.2 copy "xrpc: ^0.5.2" to clipboard
xrpc: ^0.5.2 copied to clipboard

Core library for XRPC communication. This is a wrapped HTTP client for AT Protocol.

2
likes
150/ 160
pub points
19%
popularity

We analyzed this package 33 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

79 out of 105 API elements (75.2 %) have documentation comments.

Some symbols that are missing documentation: http, http.get, http.post, xrpc, xrpc.EmptyData.EmptyData.fromJson.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
freezed_annotation ^2.4.1 2.4.1 2.4.1
http ^1.2.1 1.2.1 1.2.1
json_annotation ^4.8.1 4.9.0 4.9.0
mime ^1.0.5 1.0.5 1.0.5
nsid ^0.4.1 0.4.1 0.4.1
web_socket_channel ^2.4.4 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.4.4` on web_socket_channel does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

2
likes
150
pub points
19%
popularity
screenshot

Publisher

verified publisheratprotodart.com

Core library for XRPC communication. This is a wrapped HTTP client for AT Protocol.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#atproto #bluesky #http #xrpc

Documentation

Documentation
API reference

Funding

Consider supporting this project:

github.com

License

BSD-3-Clause (LICENSE)

Dependencies

freezed_annotation, http, json_annotation, mime, nsid, web_socket_channel

More

Packages that depend on xrpc