windows_system 0.1.0+1 copy "windows_system: ^0.1.0+1" to clipboard
windows_system: ^0.1.0+1 copied to clipboard

Provides access to WinRT APIs from the Windows.System namespace using FFI.

3
likes
140/ 160
pub points
17%
popularity

We analyzed this package 10 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/dart-windows/dartwinrt/issues?q=is%3Aopen+is%3Aissue+label%3A%22pkg%3A+windows_system%22 was unreachable. Make sure that the website is reachable via HEAD requests.

Documentation URL doesn't exist.

At the time of the analysis https://dartwinrt.dev was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: windows_system,
    • contains a version property, and,
    • does not contain a publish_to property.

packages/windows_system/pubspec.yaml from the repository URL mismatch: expected https://github.com/dart-windows/dartwinrt but got https://github.com/halildurmus/dartwinrt.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

106 out of 361 API elements (29.4 %) have documentation comments.

Some symbols that are missing documentation: windows_system.BatteryStatus.value, windows_system.EnergySaverStatus.value, windows_system.FolderLauncherOptions.desiredRemainingView, windows_system.FolderLauncherOptions.FolderLauncherOptions.fromPtr, windows_system.FolderLauncherOptions.itemsToSelect.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:windows_system/windows_system.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:windows_system/windows_system.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:windows_system/windows_system.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:windows_system/windows_system.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:windows_system/windows_system.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 113 issues. Showing the first 2:

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/ifolderlauncheroptions.dart:35:14

   ╷
35 │             .elementAt(6)
   │              ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ifolderlauncheroptions.dart

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/iknownuserpropertiesstatics.dart:36:16

   ╷
36 │               .elementAt(6)
   │                ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/iknownuserpropertiesstatics.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
win32 ^5.0.3 5.5.1 5.5.1
windows_applicationmodel ^0.2.0 0.2.0 0.2.0
windows_foundation ^0.2.0 0.2.0 0.2.0
windows_storage ^0.2.0 0.2.0 0.2.0
windows_ui ^0.2.0 0.2.0 0.2.0
Transitive dependencies
Package Constraint Compatible Latest
windows_data - 0.2.0 0.2.0
windows_devices - 0.2.0 0.2.0
windows_globalization - 0.1.0+1 0.1.0+1
windows_graphics - 0.2.0 0.2.0
windows_media - 0.2.0 0.2.0
windows_networking - 0.2.0 0.2.0
windows_perception - 0.1.0 0.1.0
windows_security - 0.1.0+1 0.1.0+1
windows_services - 0.1.0 0.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.