windows_foundation 0.2.0 copy "windows_foundation: ^0.2.0" to clipboard
windows_foundation: ^0.2.0 copied to clipboard

Provides access to WinRT APIs from the Windows.Foundation namespace using FFI.

4
likes
120/ 160
pub points
54%
popularity

We analyzed this package 6 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/dart-windows/dartwinrt/issues?q=is%3Aopen+is%3Aissue+label%3A%22pkg%3A+windows_foundation%22 was unreachable. Make sure that the website is reachable via HEAD requests.

Documentation URL doesn't exist.

At the time of the analysis https://dartwinrt.dev was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: windows_foundation,
    • contains a version property, and,
    • does not contain a publish_to property.

packages/windows_foundation/pubspec.yaml from the repository URL mismatch: expected https://github.com/dart-windows/dartwinrt but got https://github.com/halildurmus/dartwinrt.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

265 out of 554 API elements (47.8 %) have documentation comments.

Some symbols that are missing documentation: internal.AsyncStatus.value, internal.IAsyncAction.cancel, internal.IAsyncAction.close, internal.IAsyncAction.completed, internal.IAsyncAction.errorCode.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:windows_foundation/windows_foundation.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:windows_foundation/windows_foundation.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:windows_foundation/windows_foundation.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:windows_foundation/windows_foundation.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:windows_foundation/windows_foundation.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 807 issues. Showing the first 2:

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/collections/iiterable.dart:85:10

   ╷
85 │         .elementAt(6)
   │          ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/collections/iiterable.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/collections/iiterator.dart:145:9

    ╷
145 │         return _IIteratorRectInt32.fromPtr(ptr) as IIterator<T>;
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/collections/iiterator.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.2 2.1.2 2.1.2
win32 ^5.0.4 5.5.1 5.5.1
windows_data ^0.2.0 0.2.0 0.2.0
windows_devices ^0.2.0 0.2.0 0.2.0
windows_graphics ^0.2.0 0.2.0 0.2.0
windows_media ^0.2.0 0.2.0 0.2.0
windows_networking ^0.2.0 0.2.0 0.2.0
windows_perception ^0.1.0 0.1.0 0.1.0
windows_services ^0.1.0 0.1.0 0.1.0
windows_storage ^0.2.0 0.2.0 0.2.0
windows_ui ^0.2.0 0.2.0 0.2.0
Transitive dependencies
Package Constraint Compatible Latest
windows_applicationmodel - 0.2.0 0.2.0
windows_globalization - 0.1.0+1 0.1.0+1
windows_security - 0.1.0+1 0.1.0+1
windows_system - 0.1.0+1 0.1.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • UNDEFINED_FUNCTION - lib/src/internal/helpers.dart:23:14 - The function 'GetRestrictedErrorInfo' isn't defined.
  • UNDEFINED_FUNCTION - lib/src/internal/helpers.dart:30:33 - The function 'IRestrictedErrorInfo' isn't defined.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.