win32 5.5.1 copy "win32: ^5.5.1" to clipboard
win32: ^5.5.1 copied to clipboard

A Dart library for accessing common Win32 APIs using FFI. No C required!

744
likes
160/ 160
pub points
98%
popularity

We analyzed this package 6 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5617 out of 19308 API elements (29.1 %) have documentation comments.

Some symbols that are missing documentation: advapi32, bluetooth, com, comctl32, comdlg32.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.1.2 2.1.2 2.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

744
likes
160
pub points
98%
popularity

Publisher

verified publisherwin32.pub

A Dart library for accessing common Win32 APIs using FFI. No C required!

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#win32 #windows #ffi

Documentation

Documentation
API reference

License

BSD-3-Clause (license)

Dependencies

ffi

More

Packages that depend on win32