web_benchmarks 1.2.1 copy "web_benchmarks: ^1.2.1" to clipboard
web_benchmarks: ^1.2.1 copied to clipboard

A benchmark harness for performance-testing Flutter apps in Chrome.

9
likes
110/ 140
pub points
84%
popularity

We analyzed this package 7 days ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+web_benchmarks%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

136 out of 139 API elements (97.8 %) have documentation comments.

Some symbols that are missing documentation: analysis, client, server.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:web_benchmarks/client.dart that imports:
  • package:web_benchmarks/src/recorder.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform iOS

Because:

  • package:web_benchmarks/client.dart that imports:
  • package:web_benchmarks/src/recorder.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform Windows

Because:

  • package:web_benchmarks/client.dart that imports:
  • package:web_benchmarks/src/recorder.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform Linux

Because:

  • package:web_benchmarks/client.dart that imports:
  • package:web_benchmarks/src/recorder.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform macOS

Because:

  • package:web_benchmarks/client.dart that imports:
  • package:web_benchmarks/src/recorder.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform Web

Because:

  • package:web_benchmarks/analysis.dart that imports:
  • package:web_benchmarks/server.dart that imports:
  • package:web_benchmarks/src/runner.dart that imports:
  • package:web_benchmarks/src/browser.dart that imports:
  • package:webkit_inspection_protocol/webkit_inspection_protocol.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
flutter_test flutter 0.0.0 0.0.0
logging ^1.0.2 1.2.0 1.2.0
meta ^1.7.0 1.12.0 1.15.0
path ^1.8.0 1.9.0 1.9.0
process >=4.2.4 <6.0.0 5.0.2 5.0.2
shelf ^1.2.0 1.4.1 1.4.1
shelf_static ^1.1.0 1.1.2 1.1.2
test ^1.19.5 1.25.2 1.25.5
web ^0.5.0 0.5.1 0.5.1
webkit_inspection_protocol ^1.0.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 68.0.0
analyzer - 6.4.1 6.5.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
coverage - 1.8.0 1.8.0
crypto - 3.0.3 3.0.3
fake_async - 1.3.1 1.3.1
file - 7.0.0 7.0.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
platform - 3.1.4 3.1.4
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
shelf_packages_handler - 3.0.2 3.0.2
shelf_web_socket - 1.0.4 2.0.0
sky_engine - 0.0.99 0.0.99
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
test_core - 0.6.0 0.6.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.2
watcher - 1.1.0 1.1.0
web_socket_channel - 2.4.5 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.