web3dart 1.2.3
web3dart: ^1.2.3 copied to clipboard

Dart library to connect to Ethereum clients. Send transactions and interact with smart contracts!

51
likes
65 / 110
pub points
90 %
popularity

We analyzed this package on Apr 9, 2021, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:67:1

   ╷
67 │ <a href="http://truffleframework.com/">truffle</a> and <a href="http://truffleframework.com/ganache/">ganache</a>. All these options will give you
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 256 out of 366 API elements (69.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:web3dart/web3dart.dart that imports:
  • package:isolate/isolate.dart that imports:
  • package:isolate/registry.dart that imports:
  • package:isolate/ports.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/contracts/abi/abi.dart:143:9

    ╷
143 │         arrayLengths.insert(0, null);
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/contracts/abi/abi.dart

INFO: DO use curly braces for all flow control structures.

lib/src/contracts/abi/abi.dart:145:9

    ╷
145 │         arrayLengths.insert(0, int.parse(insideSquareBrackets));
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/contracts/abi/abi.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.13.0.0
http^0.12.00.12.20.13.1
isolate^2.0.02.0.32.0.3
json_rpc_2^2.1.02.2.22.2.2
meta^1.1.01.3.01.3.0
pointycastle^1.0.11.0.23.0.1
stream_channel^2.0.02.1.02.1.0
typed_data^1.1.61.3.01.3.0
uuid^2.0.02.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

51
likes
65
pub points
90%
popularity

Publisher

simonbinder.eu

Dart library to connect to Ethereum clients. Send transactions and interact with smart contracts!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

convert, http, isolate, json_rpc_2, meta, pointycastle, stream_channel, typed_data, uuid

More

Packages that depend on web3dart