user_feed 0.1.43-nullsafety
user_feed: ^0.1.43-nullsafety copied to clipboard

A package for viewing a user's feed

Release Maintained

user_feed #

user_feed is an open source project — it's one among many other shared libraries that make up the wider ecosystem of software made and open sourced by Savannah Informatics Limited.

A shared library for BeWell-Consumer and BeWell-Professional that is responsible for rendering and refreshing user-feed and engagement.

Installation Instructions #

Use this package as a library by depending on it

Run this command:

  • With Flutter:
flutter pub add user_feed

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  user_feed: ^0.1.43-nullsafety

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Lastly:

Import it like so:

import 'package:user_feed/user_feed.dart';

Usage #

Check the example provided for how to use this package.

Dart & Flutter Version #

  • Dart 2: >= 2.12
  • Flutter: >=2.0.0

Developing & Contributing #

First off, thanks for taking the time to contribute!

Be sure to check out detailed instructions on how to contribute to this project here and go through out Code of Conduct.

GPG Signing: As a contributor, you need to sign your commits. For more details check here

License #

This library is distributed under the MIT license found in the LICENSE file.