uri 0.11.3+1

Dart native js
Flutter Android iOS web

Utilities for building and parsing URIs

4
likes
75 / 110
pub points
93 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:8:40

  ╷
8 │ <p>UriTemplate is an implementation of <a href="http://tools.ietf.org/html/rfc6570">RFC 6570 URI Templates</a>. URI Templates are useful for generating URIs from data. UriTemplates are created from a template string, and then expanded with data to generate a URI:</p>
  │                                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 50 API elements (40.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 67 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/matchers.dart:10:1

   ╷
10 │ ┌ /**
11 │ │  * Matches the individual parts of a [Uri]. If a matcher is not specified for a
12 │ │  * part, the default matcher is [anything]. This allows you to just match on a
13 │ │  * single part, like the scheme, while ignoring the rest.
14 │ └  */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/matchers.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/matchers.dart:16:18

   ╷
16 │         {fragment: anything,
   │                  ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/matchers.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
matcher>=0.12.0 <0.13.00.12.90.12.9
quiver>=2.0.0 <3.0.02.1.32.1.3
utf>=0.8.10 <=0.10.00.9.0+50.9.0+5
Transitive dependencies
PackageConstraintCompatibleLatest
meta-1.2.31.2.3
path-1.7.01.7.0
stack_trace-1.9.51.9.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs