unofficial_jisho_api 1.1.0
unofficial_jisho_api: ^1.1.0 copied to clipboard

An unofficial api for searching and scraping the japanese dictionary Jisho.org

4
likes
90 / 130
pub points
47 %
popularity

We analyzed this package on Jun 10, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 111 out of 225 API elements (49.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/exampleSearch.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/objects.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
html^0.14.0+30.14.0+40.15.0
html_unescape^1.0.1+31.0.22.0.0
http^0.12.10.12.20.13.3
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
csslib-0.16.20.17.0
http_parser-3.1.44.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.14.0+3` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

The constraint `^1.0.1+3` on html_unescape does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions html_unescape to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Dart 2.13.1.

4
likes
90
pub points
47%
popularity

Publisher

h7x4.xyz

An unofficial api for searching and scraping the japanese dictionary Jisho.org

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

html, html_unescape, http

More

Packages that depend on unofficial_jisho_api