tmi 0.0.4
tmi: ^0.0.4 copied to clipboard

Dart library for the Twitch Messaging Interface. (Twitch.tv)

4
likes
80 / 130
pub points
32 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 44 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:tmi/tmi.dart that imports:
  • package:websok/io.dart that imports:
  • package:web_socket_channel/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
eventify^0.1.40.1.61.0.0
logger^0.9.10.9.41.0.0
websok^2.1.22.1.22.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
meta-1.7.01.7.0
stream_channel-2.1.02.1.0
typed_data-1.3.01.3.0
web_socket_channel-1.2.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.4` on eventify does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions eventify to update the constraint.

The constraint `^0.9.1` on logger does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

4
likes
80
pub points
32%
popularity

Dart library for the Twitch Messaging Interface. (Twitch.tv)

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

eventify, logger, websok

More

Packages that depend on tmi