tilt 0.0.2 copy "tilt: ^0.0.2" to clipboard
tilt: ^0.0.2 copied to clipboard

Easy access to the current tilt on `x` and `y` axis.

4
likes
120/ 140
pub points
65%
popularity

We analyzed this package 45 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 12 API elements (75.0 %) have documentation comments.

Some symbols that are missing documentation: tilt, tilt.DeviceTilt, tilt.DeviceTilt.DeviceTilt.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:tilt/tilt.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:tilt/tilt.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:tilt/tilt.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:tilt/tilt.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
sensors_plus ^1.3.0 1.4.1 5.0.1
stream_transform ^2.0.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
plugin_platform_interface - 2.1.8 2.1.8
sensors_plus_platform_interface - 1.2.0 1.2.0
sensors_plus_web - 1.1.2 1.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on sensors_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sensors_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

4
likes
120
pub points
65%
popularity

Publisher

unverified uploader

Easy access to the current tilt on `x` and `y` axis.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, sensors_plus, stream_transform

More

Packages that depend on tilt