threads_client 0.1.10
threads_client: ^0.1.10

Dart client for Textile threads (https://textile.io) a database built on IPFS.

2
likes
55 / 110
pub points
6 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 74 API elements (73.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:threads_client/threads_client.dart that imports:
  • package:threads_client/src/models.dart that imports:
  • dart:ffi
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 57 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:threads_client_grpc/api.pbgrpc.dart'.

lib/src/client.dart:7:8

  ╷
7 │ import 'package:threads_client_grpc/api.pbgrpc.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/client.dart

ERROR: Target of URI hasn't been generated: 'package:threads_client_grpc/api.pb.dart'.

lib/src/client.dart:8:8

  ╷
8 │ import 'package:threads_client_grpc/api.pb.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/client.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.2.02.4.22.4.2
base32^1.1.11.1.21.1.2
cryptoutils^0.4.00.4.00.4.0
grpc^2.1.32.8.02.8.0
protobuf^1.0.11.1.01.1.0
threads_client_grpc^0.1.150.1.231.0.1
uuid^2.0.42.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
fixnum-0.10.110.10.11
googleapis_auth-0.2.120.2.12
http-0.12.20.12.2
http2-1.0.11.0.1
http_parser-3.1.43.1.4
meta-1.2.41.2.4
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.15` on threads_client_grpc does not support the latest published version `1.0.1`

pubspec.yaml:11:24

   ╷
11 │   threads_client_grpc: ^0.1.15
   │                        ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
55
pub points
6%
popularity

Publisher

textile.io

Dart client for Textile threads (https://textile.io) a database built on IPFS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, base32, cryptoutils, grpc, protobuf, threads_client_grpc, uuid

More

Packages that depend on threads_client