threads_client_grpc 0.1.9

This is a support library used by the Dart Threads Client, available on here.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  threads_client_grpc: ^0.1.9

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:threads_client_grpc/api.pb.dart';
import 'package:threads_client_grpc/api.pbenum.dart';
import 'package:threads_client_grpc/api.pbgrpc.dart';
import 'package:threads_client_grpc/api.pbjson.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 26, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/api.pbjson.dart. (-25 points)

Analysis of lib/api.pbjson.dart reported 148 hints, including:

line 8 col 30: Avoid const keyword.

line 12 col 28: Avoid const keyword.

line 14 col 8: Avoid const keyword.

line 15 col 5: Avoid const keyword.

line 19 col 36: Avoid const keyword.

Format lib/api.pb.dart.

Run dartfmt to format lib/api.pb.dart.

Format lib/api.pbenum.dart.

Run dartfmt to format lib/api.pbenum.dart.

Maintenance issues and suggestions

Provide a file named (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and threads_client_grpc.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
async ^2.2.0 2.4.0
grpc ^2.1.3 2.1.3
protobuf ^1.0.1 1.0.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
fixnum 0.10.11
googleapis_auth 0.2.11+1
http 0.12.0+4
http2 1.0.0
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pedantic 1.9.0
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
pubspec_version ^0.6.1