tapegen 0.0.2

Dart native

Tool for generating code for tape, a type-safe and future- and backwards-compatible serializer for Dart objects.

0
likes
70 / 110
pub points
1 %
popularity

We analyzed this package on Aug 12, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 3 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:tapegen/tapegen.dart that imports:
  • package:tapegen/src/tape_generator.dart that imports:
  • package:tapegen/src/utils.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: `Future` results in `async` function bodies must be `await`ed or marked `unawaited` using `package:pedantic`.

bin/commands/assist.dart:59:5

   ╷
59 │     tapeDartFile.registerAdapters(adapters);
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/commands/assist.dart

INFO: This function has a return type of 'String', but doesn't end with a return statement.

bin/commands/doctor.dart:47:8

   ╷
47 │ String _getDependencyInfos(Dependency dependency) {
   │        ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/commands/doctor.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.80.39.170.39.17
args^1.6.01.6.01.6.0
build>=0.12.6 <2.0.01.3.01.3.0
build_config>=0.4.2 <1.0.00.4.20.4.2
console^3.1.03.1.03.1.0
dart_style^1.3.61.3.61.3.6
dartx^0.4.10.4.20.5.0
glob^1.2.01.2.01.2.0
meta^1.1.01.2.21.2.2
path^1.7.01.7.01.7.0
pub_semver^1.4.41.4.41.4.4
pubspec_parse^0.1.50.1.50.1.5
source_gen^0.9.00.9.60.9.6
string_similarity^1.0.11.1.01.1.0
tape^0.0.30.0.30.0.3
watcher^0.9.7+150.9.7+150.9.7+15
yaml^2.2.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.07.0.0
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
characters-1.0.01.0.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
coverage-0.14.00.14.0
crypto-2.1.52.1.5
csslib-0.16.20.16.2
html-0.14.0+30.14.0+3
http-0.12.20.12.2
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-3.0.13.0.1
logging-0.11.40.11.4
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pool-1.4.01.4.0
shelf-0.7.80.7.8
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.80.2.8
shelf_web_socket-0.2.30.2.3
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
test_api-0.2.180.2.18
test_core-0.3.110.3.11
time-1.3.01.3.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
vm_service-4.2.04.2.0
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.30.7.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.1` on dartx does not support the latest published version `0.5.0`

pubspec.yaml:17:10

   ╷
17 │   dartx: ^0.4.1
   │          ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
1%
popularity

Tool for generating code for tape, a type-safe and future- and backwards-compatible serializer for Dart objects.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

marcel.garus@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, args, build, build_config, console, dart_style, dartx, glob, meta, path, pub_semver, pubspec_parse, source_gen, string_similarity, tape, watcher, yaml

More

Packages that depend on tapegen