talker_http_logger 0.1.0-dev.8 copy "talker_http_logger: ^0.1.0-dev.8" to clipboard
talker_http_logger: ^0.1.0-dev.8 copied to clipboard

Lightweight and customizable http client logger on talker base

7
likes
160/ 160
pub points
81%
popularity

We analyzed this package 3 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 34 API elements (52.9 %) have documentation comments.

Some symbols that are missing documentation: talker_http_logger, talker_http_logger.HttpRequestLog, talker_http_logger.HttpRequestLog.HttpRequestLog, talker_http_logger.HttpRequestLog.key, talker_http_logger.HttpRequestLog.request.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http_interceptor ^2.0.0-beta.7 2.0.0 2.0.0
talker ^4.3.2 4.3.2 4.3.2
Transitive dependencies
Package Constraint Compatible Latest
ansicolor - 2.0.2 2.0.2
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
http - 1.2.1 1.2.1
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
talker_logger - 4.3.2 4.3.2
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

7
likes
160
pub points
81%
popularity

Publisher

verified publisherfrezycode.com

Lightweight and customizable http client logger on talker base

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (license)

Dependencies

http_interceptor, talker

More

Packages that depend on talker_http_logger