super_native_extensions 0.8.15 copy "super_native_extensions: ^0.8.15" to clipboard
super_native_extensions: ^0.8.15 copied to clipboard

Low level interface various native APIs such as clipboard and Drag and Drop. Not meant to be used directly.

4
likes
120/ 140
pub points
83%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

115 out of 414 API elements (27.8 %) have documentation comments.

Some symbols that are missing documentation: raw_clipboard, raw_clipboard.ClipboardEvents, raw_clipboard.ClipboardEvents.ClipboardEvents, raw_clipboard.ClipboardEvents.instance, raw_clipboard.ClipboardEvents.registerCopyEventListener.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:super_native_extensions/raw_drag_drop.dart that imports:
  • package:super_native_extensions/src/drag_interaction/long_press_handler.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:super_native_extensions/raw_drag_drop.dart that imports:
  • package:super_native_extensions/src/drag_interaction/long_press_handler.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package not compatible with platform Windows

Because:

  • package:super_native_extensions/super_native_extensions_web.dart that imports:
  • package:flutter_web_plugins/flutter_web_plugins.dart that imports:
  • package:flutter_web_plugins/src/plugin_registry.dart that imports:
  • dart:ui_web
Package does not support platform `Linux`.

Because:

  • package:super_native_extensions/raw_drag_drop.dart that imports:
  • package:super_native_extensions/src/drag_interaction/long_press_handler.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:super_native_extensions/raw_drag_drop.dart that imports:
  • package:super_native_extensions/src/drag_interaction/long_press_handler.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:super_native_extensions/raw_drag_drop.dart that imports:
  • package:super_native_extensions/src/drag_interaction/long_press_handler.dart that imports:
  • package:super_native_extensions/src/drag_interaction/interaction_session.dart that imports:
  • package:super_native_extensions/src/drag_interaction/overlay_widget.dart that imports:
  • package:super_native_extensions/src/drag_interaction/overlay_layout.dart that imports:
  • package:pixel_snap/pixel_snap.dart that imports:
  • package:pixel_snap/src/widgets/debug_bar/debug_bar.dart that imports:
  • package:pixel_snap/src/generated/widgets.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The argument type 'String' isn't related to 'JSString'.

lib/src/web/drop.dart:39:55

   ╷
39 │   final hasFiles = dataTransfer.types.toDart.contains("Files");
   │                                                       ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/web/drop.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
device_info_plus ^10.0.1 10.1.0 10.1.0
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
irondash_engine_context ^0.5.3 0.5.3 0.5.3
irondash_message_channel ^0.7.0 0.7.0 0.7.0
meta ^1.7.0 1.12.0 1.15.0
path ^1.8.2 1.9.0 1.9.0
pixel_snap ^0.1.2 0.1.5 0.1.5
uuid ^4.1.0 4.4.0 4.4.0
web ^0.5.1 0.5.1 0.5.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
crypto - 3.0.3 3.0.3
device_info_plus_platform_interface - 7.0.0 7.0.0
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.11.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

4
likes
120
pub points
83%
popularity

Publisher

verified publishernativeshell.dev

Low level interface various native APIs such as clipboard and Drag and Drop. Not meant to be used directly.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, device_info_plus, ffi, flutter, flutter_web_plugins, irondash_engine_context, irondash_message_channel, meta, path, pixel_snap, uuid, web

More

Packages that depend on super_native_extensions