supchat_chat 1.2.0
supchat_chat: ^1.2.0 copied to clipboard

Chat module from supchat.chat

0
likes
60/ 130
pub points
1%
popularity

We analyzed this package on Oct 28, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://supchat.chat was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 233 API elements (9.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

lib/chat/bloc/bloc.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/chat/bloc/chat_bloc.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_bloc^7.0.07.3.17.3.1
flutter_linkify^5.0.05.0.25.0.2
flutter_svg^0.21.0-nullsafety.00.21.0+10.23.0+1
get_it^5.0.35.0.67.2.0
google_fonts^2.0.02.1.02.1.0
http^0.13.00.13.40.13.4
image_picker^0.7.30.7.5+40.8.4+3
intl^0.17.00.17.00.17.0
photo_view^0.5.00.5.00.13.0
url_launcher^6.0.26.0.126.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
bloc-7.2.17.2.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_plugin_android_lifecycle-2.0.42.0.4
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
linkify-4.1.04.1.0
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
path_drawing-0.5.1+10.5.1+1
path_parsing-0.2.10.2.1
path_provider-2.0.62.0.6
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
provider-6.0.16.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.21.0-nullsafety.0` on flutter_svg does not support the stable version `0.22.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint `^5.0.3` on get_it does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions get_it to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.