sse 4.1.5 copy "sse: ^4.1.5" to clipboard
sse: ^4.1.5 copied to clipboard

Provides client and server functionality for setting up bi-directional communication through Server Sent Events (SSE) and corresponding POST requests.

53
likes
110/ 140
pub points
100%
popularity

We analyzed this package 17 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

27 out of 35 API elements (77.1 %) have documentation comments.

Some symbols that are missing documentation: sse_client, sse_client.SseClient.close, sse_client.SseClient.onConnected, sse_client.SseClient.onOpen, sse_handler.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:sse/client/sse_client.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform iOS

Because:

  • package:sse/client/sse_client.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform Windows

Because:

  • package:sse/client/sse_client.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform Linux

Because:

  • package:sse/client/sse_client.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform macOS

Because:

  • package:sse/client/sse_client.dart that imports:
  • package:web/web.dart that imports:
  • package:web/src/helpers.dart that imports:
  • package:web/src/helpers/http.dart that imports:
  • package:web/src/helpers/events/events.dart that imports:
  • package:web/src/helpers/events/streams.dart that imports:
  • package:web/src/dom.dart that imports:
  • package:web/src/dom/xhr.dart that imports:
  • package:web/src/dom/html.dart that imports:
  • package:web/src/dom/webidl.dart that imports:
  • dart:js_interop
Package not compatible with platform Web

Because:

  • package:sse/server/sse_handler.dart that imports:
  • package:sse/src/server/sse_handler.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.0.8 2.11.0 2.11.0
collection ^1.0.0 1.18.0 1.18.0
logging ^1.0.0 1.2.0 1.2.0
pool ^1.5.0 1.5.1 1.5.1
shelf ^1.1.0 1.4.1 1.4.1
stream_channel ^2.0.0 2.1.2 2.1.2
web ^0.5.0 0.5.0 0.5.0
Transitive dependencies
Package Constraint Compatible Latest
http_parser - 4.0.2 4.0.2
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

53
likes
110
pub points
100%
popularity

Publisher

verified publishertools.dart.dev

Provides client and server functionality for setting up bi-directional communication through Server Sent Events (SSE) and corresponding POST requests.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

async, collection, logging, pool, shelf, stream_channel, web

More

Packages that depend on sse