sse 4.1.0
sse: ^4.1.0 copied to clipboard

Provides client and server functionality for setting up bi-directional communication through Server Sent Events (SSE) and corresponding POST requests.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add sse

With Flutter:

 $ flutter pub add sse

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  sse: ^4.1.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:sse/client/sse_client.dart';
import 'package:sse/server/sse_handler.dart';
15
likes
100
pub points
97%
popularity

Publisher

tools.dart.dev

Provides client and server functionality for setting up bi-directional communication through Server Sent Events (SSE) and corresponding POST requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

async, collection, logging, pedantic, pool, shelf, stream_channel

More

Packages that depend on sse