sqlcool 4.3.1

Flutter Android iOS

Easy and reactive Sqlite. Stream of changes, select bloc, custom database models

23
likes
90 / 110
pub points
82 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 159 out of 160 API elements (99.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Package does not support Flutter platform Linux

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.0
extra_pedantic^1.1.1+31.2.01.2.0
flutterflutter0.0.00.0.0
path_provider^1.6.01.6.161.6.16
pedantic^1.8.01.9.01.9.2
sqflite^1.2.01.3.1+11.3.1+1
synchronized^2.2.02.2.0+22.2.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
ffi-0.1.30.1.3
file-5.2.15.2.1
intl-0.16.10.16.1
meta-1.1.81.2.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.20.0.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
sky_engine-0.0.990.0.99
sqflite_common-1.0.2+11.0.2+1
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
win32-1.7.11.7.1
xdg_directories-0.1.00.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.0`

pubspec.yaml:27:20

   ╷
27 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

23
likes
90
pub points
82%
popularity

Easy and reactive Sqlite. Stream of changes, select bloc, custom database models

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ansterj@gmail.com

License

MIT (LICENSE)

Dependencies

cupertino_icons, extra_pedantic, flutter, path_provider, pedantic, sqflite, synchronized

More

Packages that depend on sqlcool