How to get the most, most value from Dart static analysis.
This is an alternative to pedantic with many additional rules.
It does contain all pedantic rules and many more.
To use extra_pedantic add it as a dev_dependency:
dev_dependencies: extra_pedantic: 1.1.1
Add this line to your
or if you want to enforce
sort_child_properties_last and disable
always_put_required_named_parameters_first (for Flutter projects)
And you're done.
The static analyzer might show you thousands of warnings, but that's OK. Fix them on your terms and you'll drastically improve your code quality, reduce ambiguity and the number of bugs in your codebase.
Feel free to add this badge to your README.
[![extra_pedantic on pub.dev](https://img.shields.io/badge/style-extra__pedantic-blue)](https://pub.dev/packages/extra_pedantic)
extra_pedantic does not contain any dart code. If you want to use
unawaited, you'll have to add
pedantic as a normal dependency.
1.1.1+3 (2019-11-3) #
- Readme updated
1.1.1+2 (2019-10-25) #
- Badges added
1.1.1+1 (2019-10-22) #
- Longer description
1.1.1 (2019-10-19) #
- Removed diagnostic_describe_all_properties
1.1.0 (2019-10-09) #
- Separated into flutter and non flutter analysis_options.yaml
- Made rules fully compatible with pedantic
1.0.0 (2019-08-16) #
- Initial version
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: extra_pedantic: ^1.1.1+3
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
Maintenance issues and suggestions
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
|Dart SDK||>2.2.2 <3.0.0|