extra_pedantic 1.1.0

  • Readme
  • Changelog
  • Installing
  • 69

extra_pedantic #

How to get the most, most value from Dart static analysis.

This is an alternative to pedantic with many additional rules.

It does contain all pedantic rules and many more!

To use extra_pedantic add it as a dev_dependency:

dev_dependencies:
  extra_pedantic: 1.1.0

Then, add this line to your analysis_options.yaml file

include: package:extra_pedantic/analysis_options.yaml

or if you want to enforce sort_child_properties_last and disable always_put_required_named_parameters_first. (for Flutter modules)

include: package:extra_pedantic/analysis_options_flutter.yaml

And you're done.

The static analyzer might show you thousands of warnings but that's OK. Fix them on your own terms and you'll drastically improve your code quality and reduce the amount of bugs in your code.

Note: extra_pedantic does not contain any dart code. If you want to use unawaited, you'll have to add pedantic as a normal dependency.

1.1.0 (2019-10-09) #

  • Separated into flutter and non flutter analysis_options.yaml
  • Made rules fully compatible with pedantic

1.0.0 (2019-08-16) #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  extra_pedantic: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
97
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Oct 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No libraries.

Maintenance suggestions

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >2.2.2 <3.0.0