spider 1.1.1
spider: ^1.1.1 copied to clipboard

A small dart command-line tool for generating dart references of assets from the assets folder.

44
likes
90 / 110
pub points
68 %
popularity

We analyzed this package on Apr 20, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/EXAMPLE.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 7 API elements (42.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:spider/spider.dart that imports:
  • package:spider/src/utils.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.02.0.0
dart_style^1.3.91.3.122.0.0
html^0.14.0+40.14.0+40.15.0
http^0.12.20.12.20.13.1
logging^0.11.40.11.41.0.1
path^1.7.01.8.01.8.0
watcher^0.9.7+150.9.7+151.0.0
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.020.0.0
analyzer-0.41.21.4.0
async-2.5.02.5.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
csslib-0.16.20.17.0
file-6.1.06.1.0
glob-2.0.12.0.1
http_parser-3.1.44.0.0
meta-1.3.01.3.0
package_config-1.9.32.0.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^1.3.9` on dart_style does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions dart_style to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

44
likes
90
pub points
68%
popularity

Publisher

birju.dev

A small dart command-line tool for generating dart references of assets from the assets folder.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

args, dart_style, html, http, logging, path, watcher, yaml

More

Packages that depend on spider